Freezing during installation on both Ubuntu 18.04 and 18.10

Hey guys,

I’m trying to install ghost on my company’s local server to use it for an internal blog but I manage to get all the way to the final step (installing ghost locally inside an empty directory) before it freezes on the message “[5/5 Building packages]”.

I’ve tried this on a VM running Ubuntu 18.04.2 as well as 18.10 to see if there would be a difference but I encountered the same problem on each.

Here are the steps I followed:

  1. Create the VM with 8 GB of RAM and 100 GB of storage space

  2. Update and upgrade packages – sudo apt-get update && sudo apt-get upgrade

  3. Install the Node Version Manager* – curl -o- | bash

  4. Reboot the VM

  5. Verifying installation of NVM – command -v nvm

  6. Install Nodejs 10.x – nvm install 10

  7. Install the Ghost CLI – npm install ghost-cli@latest -g

  8. Make and move into a new empty directory

  9. Install ghost locally (this is where it freezes on 5/5) – ghost install local

*I use NVM because I ran into an issue installing nodejs globally. I wouldn’t be able to use npm to install the ghost-cli due to a permission error. This stack overflow thread suggested using the NVM which did the trick and didn’t throw up any errors during the CLI installation. FYI, I initially also tried a sudo npm install, which did install the ghost CLI (despite it not being the recommended approach according to the error message displayed) but I ran into the same freezing issue at the last step.

I also tried leaving it in its frozen state for a couple of hours to see if it was actually doing something in the background, but it still remained frozen on “[5/5] Building packages…”

Any ideas on how I can get it working?

My company’s IT team came to the rescue. They managed to get it set up using the following commands:

  1. sudo apt-get upgrade && apt-get update
  2. adduser
  3. usermod -aG sudo
  4. su -
  5. curl -sL | sudo -E bash -
  6. apt-get install nodejs
  7. npm install ghost-cli@latest -g
  8. New Directory
  9. ghost install local

Sharing this in case anyone runs into this issue in the future.

1 Like

Appreciate sharing the solution @stefanj, thanks :pray: