Ghost adding 12 hours to publish date

Hi all,

I have a strange corner case which I haven’t encountered before. I have ghost installed in a docker installed on my unraid box, which is then connected to via a reverse proxy.

Every time I schedule a post, it adds twelve hours to the scheduled time. So 7:00 becomes 17:00, etc. If I try to reschedule it from the time it gets adjusted to, it adds another twelve hours - so 17:00 becomes 03:00 the next day.

It becomes a loop. I can see for a split second it sets the time and date correctly, then adds ten hours. But I don’t get any errors.

I’ve confirmed the time and date in the docker is correct. The same for the SQL instance AND the server itself.
I’ve tried reinstalling the docker, and changing the time from AEST (my native timezone) to UTC and back again inside ghost.

I’m running 3.19.0 and my URL is
Have only tried Chrome.

Anything you can think of would be appreciated.

Hey @Vulkan :wave:

Can you try updating Ghost to the latest version?

Currently I can’t - it looks like 3.19.2 hasn’t been made available though community applications.

3.19.1 contains a fix for timezone issues in 3.19.0; once the image gets updated, please do let us know if you’re still running into the issue

Perfect - will keep my eyes peeled for the update.