Ghost-CLI only works with Ghost versions >= 1.0.0

Ghost-CLI version: 1.12.0
Ghost version: 3.0.0 (at /var/www/ghost)

I’m just simply trying to run a ghost start or a ghost restart and I continue to get:
Ghost-CLI only works with Ghost versions >= 1.0.0.
If you are trying to upgrade Ghost LTS to 1.0.0, refer to https://ghost.org/faq/upgrade-to-ghost-1-0/.

I am doing sudo -i -u ghost-mgr and then cd /var/www/ghost to be in the working directory for ghost, but it keeps talking about Ghost-CLI. I attempted an update to the ghost CLI from the Ghost manual setup support docs, but it hasn’t changed anything.

I’m running on DigitalOcean droplet by the way. So it should be running the very latest versions of what it needs already, I can’t find anything on how to fix this and need some help.

I have made changes to config.production.json to setup external mail provider via mailgun and just need to restart ghost!

It sounds like you may have made a file called config.js in your Ghost directory? This is what the CLI uses to check for Ghost 1.0. If you remove or rename that file then the CLI should stop being confused :slight_smile:

1 Like