Ghost /ghost shows just spinning wheel

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

  • What’s your URL? This is the easiest way for others to debug your issue
  • What version of Ghost are you using?
  • What configuration?
  • What browser?
  • What errors or information do you see in the console?
  • What steps could someone else take to reproduce the issue you’re having?

Hi I am using docker:3.2.0 and hosted it locally on a cluster of rpi. I do have the site showing up. But when I get to /ghost to try to register, I get spinning wheel and stuck. I am not sure what I need to do to debug the issues. Thanks for any guidance.

Hi @Watt_Poosanguansit :wave:. Have you tried using the ghost doctor command to see if any debug information comes up?

I am running the official docker image. Do I run the ghost doctor in the image?

I managed to get the logs from one of the instance that was servicing the call:

[2020-01-06 17:02:16] INFO Ghost boot 34.023s
[2020-01-06 17:33:08] INFO “GET /ghost” 301 15ms
[2020-01-06 17:33:08] INFO “GET /ghost/” 200 663ms
[2020-01-06 17:33:09] INFO “GET /ghost/assets/vendor.min-e80c50b3effa149734ab96b786349748.css” 200 38ms
[2020-01-06 17:33:38] WARN {{#get}} helper took 501ms to complete

{{#get}} helper took 501ms to complete

Error ID:

Error Code:

api: v3.[object Object].browse
limit: 3
filter: tags:getting-started+id:-5e13680760e61b0001eaf91b
returnedRows: 3

I am not sure what I should do next. Any advice? Thanks for your help, David

@Watt_Poosanguansit if you right-click on the page whilst you’re stuck with the spinner then choose “Inspect” it will open the web inspector. The web inspector will have a “Console” tab, if you click on that then I expect there will be an error shown there which will help debug what’s going on. Can you share the error message or your site’s URL?

Thanks @Kevin. Let me get back to you on this. I will try to expose it when I get a static ip assigned in a bit.

@Kevin I do not see anything in the console tap. I have attached the screenshot here as well. In the mean time, I am still trying to expose the page on an accessible ip but I ran into some internal network issue. I will ping you when I can get that down. Thanks.

@Watt_Poosanguansit your network pane is not showing the admin’s JS files being loaded. Do you have Javascript disabled or are you using something that might be stripping/blocking JS files?

@Kevin Thank you that is the case. My bad just totally forgot that brave turns off js by default. Thanks again for your help.

1 Like

Hi @Kevin,

I was able to get ghost installed and ran in Kubernetes this morning again. So I tried to follow along setting up with admin on /ghost/ extension. I was able to get through the process once and when I tried to log in I am getting this:

Authorization failed Unable to determine the authenticated user or integration. Check that cookies are being passed through if using session authentication

I tried to delete and redeploy the deployment file but it leads to the same place. How do I resolve this issue? Also, I look at the logs and it created a number of tables and ends with 2020-02-01 20:31:47] INFO Ghost is running in production…

However, I looked around and couldn’t find ghost has written anything to the mount point. Where does ghost write out to persistent store by default? Thanks for your help.

I did get over those issues by reinstalling the docker image. and set the mount path to

  • mountPath: /var/lib/ghost/content

in my kubernetes deployment yaml. Just put it here so it might help out someone who was having the same issues in the future. Thanks.