Ghost installed locally but not working

Hi there

I have installed Ghost locally with npm install ghost-cli@latest -g.

However, when I run ghost install local I get the following error:

ghost : The term 'ghost' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is corre
ct and try again.    
At line:1 char:1     
+ ghost install local
+ ~~~~~
    + CategoryInfo          : ObjectNotFound: (ghost:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

I’m using Windows 10.

How do I make this work?

I deleted all Ghost files from both C:\Users\<username>\AppData\Roaming\npm and C:\Users\<username>\AppData\Roaming\npm\node_modules and installed the dependency again but nothing changed.

I have looked through the forum and github again to find past issues that might help me resolve this, but I still can’t get it to work, which makes the development I want to do with Ghost much more cumbersome when I don’t have a local environment running. It’s not node at least, I’m using v12.16.3.

Looks like it’s been reported here and then answered by @vikaspotluri123:

Have you tried the solution Vikas mentioned?

It works now, thanks! It required a system restart as well.

1 Like