Ghost reducing image quality

I’ve got an specific article in my ghost blog, where the images are all in bad quality, because of only god knows why.
I know that copy-pasting the entire article, will reduce the image quality, therefore I put them one by one, individually, in the article itself, by the original file. Problem is that in this specific article, that is not happening. Why? How do I solve this?
here’s the link for the article:
Panther's Compliance Integrations: Enabling Compliance & Privacy

If you have the beta editor enabled, try disabling it and make the article again from scratch. Copy and paste text but don’t copy H1 or H2 headings.

I had an issue with images not displaying at all and the beta editor was the culprit.

I’ve never enabled it. What else could it be?