Ghost saying too many open files using "ghost install local"

#1

I am trying to install Ghost as ghost install local on a Centos 7 server with cPanel.

  • What’s your URL? Cant give it because it isnt running yet
  • Version : Latest as of March 2019
    -Configuration: cPanel , on Centos 7 , installed Ghost CLI as root and ran ghost install local as a normal user
  • What browser? - Any !
  • What errors or information do you see in the console?

A: See the attached picture and below :

An unexpected error occurred: "EMFILE: too many open files, copyfile '/home/technmuscle/.cache/yarn/v4/npm-async-2.6.1-b245a23ca71930044ec53fa46aa00a3e87c6a610/node_modules/async/mapValuesSeries.js' -> '/home/technmuscle/public_html/ghost/versions/2.18.1/node_modules/async/mapValuesSeries.js'"

Screenshot:

  • What steps could someone else take to reproduce the issue you’re having?
    A: Same config that i have, Centos 7 With cPanel on top with 25000 open files limit
0 Likes

#2

@dukesx the error is coming from yarn rather than Ghost itself. Look to see if there are any yarn install errors reported for your particular OS/environment regarding too many open files and double check what the ulimit is for all users on your system.

0 Likes

#3

Hi @Kevin , I tried installing the the module it failed , it worked without Node js doing it , i cleared Yarn and restarted whole process , i tweaked the open files limits from 5000 to 25000 and i also tried to see additional errors in .ghost directory , the error logs showed nothing but the same error you see in the command prompt. Nothing seems to remove the error

0 Likes

closed #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

0 Likes