Grunt prod aborted due to warnings. (installing from source)

Hi. I followed the Install from source instructions. If i run grunt dev its working fine.

But if i run grunt build (i am trying to get a zip of the changes i made to the admin, to upload it to my server), i get this (i guess is an error):

 Running "subgrunt:prod" (subgrunt) task
Warning: The "core/server/lib/members/static/auth" directory is not valid, or does not contain a Gruntfile. Use --force to continue.

Aborted due to warnings.
➜  Ghost git:(gconfort) Running "shell:ember:prod" (shell) task

Does anyone knows how to fix this?

I tried to navigate to the mentioned folder (core/server/lib/members/static/auth) but the “members” folder does not exits within the lib folder.

I can navigate to: core/server/lib/ but i cant navigate to core/server/lib/members

After the “aborted due warnings” message i do get a “done.” Message but i don’t see any zip folder. The done message shows almost instantly, so i don’t think the zip it’s being created.

Upon further investigation i found a reference to the mentionated path on the Gruntfile on line 81. It has something to do with the express configuration. Not sure what that means.

Also when i run grunt dev it works, but while all the messages are loading on my terminal, one of them is the following one, which also mentions the same path:

Deleted the folder and did the same process again. I am gettting the same “aborted due warnings” message. It leads me to think the process is not completed.

Although as you can see i get a done at the end. Does that means i have a zip file somewhere?

And if i do grunt release i get a similar output:

lib/members directory is deleted.
Check below thread

Workaround :slight_smile:
Copy it from history and paste under /lib

What do you mean copy it from history and paste under /lib?

But isn that commit supposed to be already merged into master? It is on the commit history on the Ghost fork i made yesterday.

Oh i guess your saying to copy the lib/members from history, before it was deleted. and copy it on my local branch Oh ok. I understand now. Thanks. But isnt supposed to work without having to do that?

1 Like

@lmuzquiz I have updated the master branch on GitHub to remove all the references in the Gruntfile!

2 Likes

Thanks @fabien

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.