H1 / H2 not working on the editor (casper)

I’ve confirmed a possible bug.

When trying to use the editor to create h1 or h2, things go wrong.

Visual proof:


H1 shows as h2
H2 doesn’t even works, no matter how many times I push the H2 button; it never gets created.

When using markdown, things work as expected, but when trying to use the editor, the headings don’t work at all.

What version of Ghost are you using?
At the time, latest version: 4.36.0

How was Ghost installed and configured?
I installed ghost by doing “ghost install” on Windows (node)

What Node version, database, OS & browser are you using?
Node v16.14.0 (at the time, the latest one). Windows 10 21H1, Browsers Firefox, Chrome (updated to their latest versions)

disclaimer: I also tried by doing a clean install and I get the same result, so it wasn’t me. I am not sure if this has anything to do with casper, but with ghost.

The large “H” button adding a h2 element is expected. The post title is a H1 so it’s semantically correct for sub titles to be H2. If you need to add another H1 you can use markdown expansions or keyboard shortcuts to set any header level you want.

You need to upgrade your Ghost version to fix the smaller H button. It sounds you’re running on an old version with a bug but it was fixed before 4.36.0, I suggest double-checking which version you are running by opening the “What’s new” page in Admin and checking the info on the right.

1 Like


Ashamed of myself! Now its working!!! Thanks!

Here’s a cookie for you: