How do I add comments?


I am on a Ghost PRO plan and using the Digest theme. You can see my website here.

I enabled comments as per the documentation. However, I don’t see the comment form or a button to add comments anywhere on my website.

I first thought it was because I was logged in using my admin account. So I tried in a different browser/device, registering as a subscriber using my alternate email address, but still, no luck.

Am I missing anything? How do I get the comments form to show up?

Any help is really appreciated. Thank you!

1 Like

Have you updated to the latest version of the Digest theme?

No, I havn’t. How do I do that? FYI, I’m on the Pro (hosted) plan. So don’t have access to any source code.

Also, the documentation said:

All of our official themes support member comments by default." - source


Ghost Pro users can log in and start enjoying all of this right away! If you’re a developer, self-hosting Ghost, you’ll need to upgrade to the latest version to get access to everything that’s new. - source

So if I understand correctly, I should have access to the comments by default. :thinking:

If you are using the default theme Casper then you’d have it by default because it’s included with Ghost and so is updated when a ghost is updated.

If you’re using a different theme you need to update it yourself. For official themes you can do that by re-installing it from the design section of the admin area if you haven’t made any changes to it. If you have a 3rd party or customised theme you’ll need to update/modify it and upload it.

1 Like

Ah, I see. I am using the Digest theme. After updating the theme, the comments are working like a charm. Thank you so much @Kevin!

For anyone else having the same issue, here’s how you update the theme.

  1. Go to Settings > Design > Themes
  2. Click “Change theme”
  3. Select your theme
  4. Click “Use (your theme)”