How to add support for non-breaking spaces

#1

Hi there,

I need support for non-breaking spaces in my posts. Can you tell me how to insert them, please?

I suspect that Ghost editor removes non-breaking spaces, but I’m not sure. I figured out that I could add text with non-breaking spaces with the HTML helper (that thing that pops up when you press “+” icon), but it is not friendly at all—you basically write all the HTML by yourself. Also, you still don’t have any way to add non-breaking spaces to the page title.

I use Ghost 2.19.3 on the Ubuntu 18.04.2, but I think my problem is related to Markdown parser or whatever Ghost use under the hood.

The reason I’m asking for help is that text without non-breaking spaces violates the norms, rules, and specifics of the Russian language and screen typography. It means I can not use Ghost though I like it and don’t want to throw away without even trying to fix.

P.S. My previous post was deleted (closed) without explanation, so please tell me if something is obscure and I need to clarify it.

#2

What key combination are you using to insert a non-breaking-space? If you’re writing in rich-text or in a markdown card it should work the same as any other editor.

On macOS if you’re inside a rich-text section Option+Space inserts a non-breaking space, this equates to   in the editor and rendered content. If you’re using a markdown card you’ll need to type out HTML entities ( ) manually.

#3

Kevin, thanks a lot. I’m truly sorry for wasting your time, but option + space works like a charm :exploding_head: Previously I’ve tried external web-service. Thanks one more time :+1:

closed #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.