non-breaking space

I write articles in a macOS programme in which I can set unbroken spaces for all text in one click.

But when I copy it into the Ghost editor, all the unbroken spaces disappear.

I first thought it was a copying problem, but no. I tried pasting it into Pages and the non-breaking spaces were still there. I tried pasting into the wordpress editor and the unbroken spaces were still there too. But when I paste into the CMS Ghost editor, the unbroken spaces are changed to simple spaces and I have to set them manually.

I think this is not very good usability. Is it possible to fix it?

1 Like

Try to draft your posts in the editor.

This is not a solution to the problem. I find it convenient to write text in a third-party editor. It has additional functionality that I need and allows me to write text without access to the Internet (for example, on an airplane).

I would like to understand why the built-in editor replaces non-breaking spaces with regular spaces and fix it.

1 Like

I think I have experienced this as well and thought it was something I was doing with how I was copy/pasting the text. It seems to jumble everything together and requires a lot of work reformatting. I’ve also seen some odd behavior when using ctrl+ arrows to select text and editing and replacing, this all might be new to the new editor