How to dissable cache in production?


#1

I update my CSS files but I can’t see these changes on production. It’s a simple page for a personal project, but I can’t see my changes on live site, also if I open directly these files, but when I open with the editor everything looks fine.

So I guess is an issue from cache on Ghost, is there a way to disable “Cache”? I want to see my changes automatically.

There is my website: https://goltastico.com
I’m using: Ghost-CLI version: 1.9.6 and Ghost version: 2.3.0
That runs on Ubuntu 16.04 with Caddy as a server.
Oh and use Cloudflare but I don’t catch any asset :slight_smile:
I use Chrome, Safari and Firefox for Test, no errors in console (about Style).

So basically I just want to see my changes live when I save my files, and don’t add the “v?=XXXX” when I render my website.

Thank you for your help guys :slight_smile:


#2

There is no way to disable the cache, this sounds like a misconfiguration. Are you using the asset helper to include your CSS files? This is required.


#3

Looks like you’re using Casper. Which CSS file are you editing?


#4

I was trying to modify the screen.css file into casper/assets/css/ — but I see on built/ and I can’t modify that :confused:


#5

Yes Hannah, I’m using that, actually Casper uses that as default. :frowning:


#6

For development with Casper, I’d recommend following the development instructions here, or is that what you had been doing already, and the changes weren’t showing up?


#7

Ok, so I should install Yarn and Gulp and after these I should run these into Casper root or into themes root?

$ yarn install
$ yarn dev

So after that when I finish to edit my files I should type this…
$ yarn zip

right? or I’m lose? — lol


#8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.