How to run ghost in production mode?

Hi, This is probably a very stupid question, yet I am having trouble running Ghost in production mode.

Despite my efforts, no matter what I do Ghost always starts in local mode as evidenced by the graphic below:

Screenshot by Lightshot

Steps I have taken in order to start Ghost in production mode:

  1. Configured config.production.json: I ensured I had a config.production.json file in the root directory of my Ghost installation. This file contains all the required configurations for production, including the url, server, and database keys.

Screenshot by Lightshot

Nonetheless, if I remove the development configuration file I start receiving this error:

→ Running in development mode

A ConfigError occurred.

Error detected in the development configuration.

I do not understand why Ghost keeps trying to run in development mode when I specifically want it to run in production.

Can someone with more experience explain what am I doing wrong?

Thank you :slight_smile:

PS:This is the command I used for the installation:
ghost install --url --port 2388 --db mysql --dbhost localhost --dbport 3306 --dbname asgf_fiu --dbuser asgf_fiu --dbpass “…” --dir /home/asgf/ --process production --no-setup-linux-user --stack false --no-start

And yes I already noticed that there is no process production, I have since then changes it to local again.

Could you please share how you’re starting Ghost?

Ah already a reply, great thank you :).

Yes I tried starting ghost with several commands including:
ghost start
ghost start --production
to no avail.

Anyone, please? I am trying to run ghost normally from the terminal with ghost start when I already have declared my production configuration, and the same still doesn`t run in production mode; why is that?