Internal links suddenly changed to nofollow — how to fix?

I got an alert about several old blog posts having internal nofollow links. None of these blog posts have been edited recently and we did not manually add the “rel=nofollow” attribute, but when you inspect the pages, it’s there.

Anyone know how I can revert these back to dofollow?

Can you share an example post? It’s difficult to know why something is happening (and therefore how to fix it) without being able to see it.

This post hasn’t been updated since April and it was drafted with the basic Ghost editor. I don’t see anything in the backend that would add the Nofollow attribute but when you inspect the page, it’s there.

This post was created before I worked on this blog, so it’s possible this has always been there and was only just caught by a crawl. But either way. I can’t figure out how to make these default to dofollow as they should

Hmm, that’s an odd one. Ghost itself has never set nofollow on links so it’s not clear where it’s come from.

  • If you create a new post with links do those have the nofollow ref set?
  • Are you copy/pasting content from elsewhere?
  • Was the content in question imported from a different system?
  • How is the post in question set up, is the content normal rich-text or is it contained in a HTML/Markdown card?

I note that the site is behind Cloudflare. It could be something like scrape shield making the changes. The easiest way to check is to enable development mode, clear the page cache, and check.

1 Like
  1. No, new posts have the standard dofollow links

  2. We usually copy/paste from Google Docs but add the links manually by using the add link (see screenshot from the example post, the nofollow attribute is not included)

  3. Not to knowledge, again we normally paste from either Notion or Google Docs

  4. Post was created in the normal Ghost editor. The exmaple post does include an embedded YouTube video, but I spot checked other posts with this issue (like this one) and not all of them have embeds.

This could have been checked quickly in the editor with a simple html editor. I wonder why Ghost keeps us with only a standard visual editor.

This is so strange because except with the html widget, there is no way to add nofollow links manually, so it must be some bug? Here the first link it’s not just nofollow, but also noopener.

Thanks for the suggestion. Our devs have looked into whether Cloudfare was affecting this and have confirmed that is not the issue. They believe this is a Ghost bug, as others have suggested.

@Kevin I’ve provided and update and this looks to be a Ghost bug. Can you or someone from your team assist? We currently have no way to even manually change the nofollow links back to dofollow.

Additional information: We’ve been using version 5.24.2 since December 2022 abd the example article (as well as the others affected by this) were published after that date. We have not updated our version or those individual posts.

I suggest you to update ghost.