Need help with DNS setup

I have a EC2 Instance running on AWS.

I have installed ghost on the server.

I have also assigned an Elastic IP to the instance.

I am using amazon’s Route 53 for my DNS management, so I Added the IP as an A record for my domain DNS settings.

When checking a DNS lookup service my domain correctly points to the IP.

Ghost install says its located at But my browser is unable to load the website.

I followed every step of the official install guide. How do I fix this issue?

Thank you so much.

Your DNS looks good, and matches what you’ve shared in your post.

However, you don’t appear to have set up a server at this address. As a first step to diagnosing the issue, check the following:

  1. Ghost is running, i.e., ghost ls
  2. The Nginx server is running: systemctl status nginx.service
  3. Ports 80 and 443 are open on the server: ufw status (if you’re using a cloud firewall, then you’ll need to check this, too)

Thank you for the speedy response :slightly_smiling_face:

  1. Yes

  2. Active

  3. I got the output, Status: inactive.

What is the fix?

A quick search suggests that EC2 blocks ports by default, so you’ll need to create an inbound rule under network and security.

Thank you so much, I added rules to open up ports 80 and 443.

I then re-ran ghost setup.

I now get this message show up on the site.

Did you setup Ghost and Nginx? For one, if you tried to setup Let’s Encrypt during installation, it would have failed since there was no route to host.

So, are you using WWW or the bare domain? Is SSL enabled? What do the logs tell you?

I have setup both. After opening the ports up, I re-ran the ssl setup command. It looked like it worked.

I’ll try deleting ghost and re-installing it with the ports open and see how that goes.



Thank you so much for all your help mjw! I am grateful.