Newsletter "View Online" Links Are Broken

Ghost version 3.40.2
Running on a digital Ocean Ubuntu droplet
Mailgun used to send newsletter
website keeganleary.com

Hello,

Thanks for all the great work. I love using Ghost.

I recently setup email newsletters and have been successful sending the emails, but the “View Online” link doesn’t seem to be working.

Post that I wrote and send an email update to my users about:
https://keeganleary.com/book-recap-indistractable-by/

Link as it appears in the email:
http://email.mail.keeganleary.com/c/eJxdjr0OwjAMhJ-m2VI5iZ2QIQMC-h75haiBohIG3p4CG5Ll4Tuf75JDi6Ajq06CFCAAhUVLYhSjBDocjlqcJiXtJNWAcPW1jXPOZ39r2a-vMS5XdnFmF0zIpgTUxpClgkmUiLZ4IG1Bs-Yuvd8fg9oPctrm78VGwrLMfM3R33m9pfroq4_dh5Z5eG0yW93v-ufcqpy_XT753YVnm3n-APbdvCZHpSgjKCcKu6gBcyGlwZo3oKNKjw

Not really sure where to start with this one. I’m thinking it may be an issue with email tracking feature that I have enabled (but doesn’t register when my subscribers actually open the email). If there’s a good resource to get started troubleshooting this please let me know! Thanks!

Keegan

You need to configure email.mail.keeganleary.com to point to MailGun

Since this is a mailgun issue, I think this hc article should help you narrow down and fix the issue :slight_smile:

Thanks for the quick response! I have the following CNAME record on Mailgun (see attached) so thought I did have email.mail.keeganleary.com pointing to mailgun.org. Will read through he article and see what I need to do.

To be clear, you need to add the CNAME record to your domain through your DNS provider (looks to be NameCheap), Mailgun is telling you what to do :wink:

OK thanks, I’m on support with Namecheap and they are having me try some different hostnames.

I have tried email.mail.keeganleary.com, email.mail which provide good verification but still broken link. Also tried @ but not working. “email” as hostname doesn’t resolve.

thanks again, will keep troubleshooting.

I get the following from nslookup but links in email are still not working.

nslookup -q=cname email.mail.keeganleary.com

Server: 75.75.75.75

Address: 75.75.75.75#53

Non-authoritative answer:

email.mail.keeganleary.com canonical name = mailgun.org.

Authoritative answers can be found from:

The link you pasted works for me now, does it work for you? If not, can you try incognito?

1 Like

Thanks,

It’s still not working for me in incognito mode but glad to hear it works for you!

I think the issue is related mailgun not writing links with https. I set up a Cloudflare account to try and rectify via the below help documentation. If it works for everyone else then that’s fine! I clear cache and history and see what happens.

Everything seems to working now after clearing cache. Thanks again for the prompt help!

1 Like