Node v. 14.16.1 makes warnings

Hey :slight_smile:

I have just updated the node version and my NPM to the following versions…

node v14.16.1
NPM: 7.12.1
And to the last version of Ghost-CLI

But after the update ghost to 4.5.0, I get this warning…

Warning: Ghost is running with node v12.22.1.
Your current node version is v14.16.1.

But my node version is: v14.16.1.

BTW… Here are some from the update list…

Bumped minimum Node version to 12.22.1 and 14.16.1 - Daniel Lockyer

How to fix it?

//Thomas -

How did you install node?

We recommend against using nvm in production because you can end up with different OS users having different versions of node installed without realising it (this is why we added the warning). It’s recommended to uninstall nvm and install node directly system-wide

Hi :slight_smile:

Thanks for the answer…

I use these commands.

  1. sudo npm install n -g
  2. sudo n stable
  3. sudo npm install -g npm

EDIT: I have just installed node 12, and it works fine without any errors! - But node 14 makes errors!

The reason running with node 14 causes errors is because the CLI is finding Ghost running a different version. In other words, the CLI node version is not the same as the Ghost node version, which is why Kevin said using something like nvm (or n) is not suggested

1 Like