Notification error in version numbers

I just updated a brand new 4.19.1 install to 4.20.1, yet under the /whatsnew page it states that while the current version is 4.20.1, that I should update to 4.20.0.

Screen Shot 2021-10-23 at 10.15.22 am

@naz I heard you were working on some notification improvements. Might this therefore be part of your realm?

As a side note, I can’t see any areas within the admin where I might adjust any kind of offers (nor custom settings). Might that imply something wrong with the install (as opposed to a notification problem), or might that just be an oversight in one way or another on my behalf?

For anybody wondering, looks like the “side note” is nothing more than the developer flag that was mistakenly left to true.