Permission denied when updating: Source theme linking

Getting an error when updating self-hosted, with permission linking problem to new Source theme. Error as follows. I’m guessing it’s because I don’t actually have that theme?

:heavy_multiplication_x: Linking built-in themes
An error occurred.
Message: ‘EACCES: permission denied, symlink ‘/srv/www/sitename/current/content/themes/source’ → ‘/srv/www/sitename/content/themes/source’’

3 Likes

I recommend checking what the owners and permissions are on those two paths mentioned.

You can use ls -l filename to check that.

1 Like

The second is a symlnked folder, and it obviously doesn’t exist given the symlink permission denied error. The first folder has the same permissions as the rest of the themes.

1 Like

I’m seeing the exact same issue.

Is there a problem with the installer script?

Huh strange, I can’t reproduce this when doing a v5.66.1 → v5.67.0 update :thinking:

Can you give the output of the following commands?

whoami
ls -la /<ghostdir>/content/themes
ls -la /<ghostdir>/current/content/themes/
1 Like

Hey there,

I came across the same error while updating my Ghost instance from v5.65.0 to v6.67.0 via Ghost CLI.

After I got the “EACCES: permission denied, symlink” error, I had to create the symlink manually to fix the issue, I ran the following commands:

sudo ln -s /var/www/site_name/current/content/themes/source /var/www/site_name/content/themes/source
cd /var/www/site_name/ && sudo chown -R ghost:ghost ./content
ghost start

Update: I think I’ve found the issue. Will come back when I have more

1 Like

Ghost-CLI v1.25.2 should now contain the fix for this: Release v1.25.2 · TryGhost/Ghost-CLI · GitHub

You can either update to that, and then rollback and update Ghost again, or use the workaround that @JuanDelgadillo posted right above (I’d probably do this one)

Thanks for the report :slightly_smiling_face:

5 Likes

Yep, I realised that updating ghost-cli stops the error from happening :+1:

npm install -g ghost-cli@latest

1 Like

I got this error and my Ghost version is 5.66

The theme “Source” was installed successfully but we detected some errors.

Errors

Highly recommended to fix, functionality could be restricted

  • [

package.json property "config.custom" contains too many settings

](Ghost Admin)Remove key from "config.custom" in your package.json to have less than or exactly 15 settings.
Check the package.json documentation for further information.

Affected files:
  • package.json

Solved with the update.

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.