Preview not visible

Hey, I have the same problem. I use a Cloudflare domain, and I configured it on my home server, but when I use HTTP in my Docker config file, it works but doesn’t give a preview, and when I use HTTPS in the config file, it doesn’t even load. I use nginx for reverse proxy, and I tried to change both HTTP and HTTPS in nginx reverse proxy, but it still doesn’t work when HTTPS is in the config file.

If Cloudflare is set to proxy, change it to DNS only. That’ll help narrow down where the problem is.

1 Like

Try opening the Developer Tools and checking out the Network Tab to see if there are HTTP requests which are not successful and the Console tab to see if there any JavaScript errors.

Expanding on what @markstos said, your site is configured as, but it needs to be configured as (https).

1 Like

@markstos I did HTTP because it works but did not give a preview. Now I did HTTPS. here is what I did for HTTPS, but the site is not working.

Your website is returning a 502 gateway error when Cloudflare attempts to contact it:

According to your screenshot, the IP of your website is That’s in a private IP address range that Cloudflare is not going to be able to reach.

You need to host your website on a public IP address that Cloudflare can reach.

I’m not sure what you are using Cloudflare for, but you could simplify your debugging by trying to set up hosting first without the complexity of including Cloudflare, and then adding it back later.

Bro, trust me, it’s not in private IP; I use nginx reverse proxy for proxying in my network. And this is the error, what I am talking about. It happens when I use HTTPS in the config. Now go to the site again. I did HTTP in the Docker config file, and now you can load my site.

But site loads and low preview don’t :smiling_face_with_tear:

How does your Nginx config look? How does it handle SSL?

Cloudflare SSL/TLS and i think this is causes problem :thinking:

I don’t use Cloudflare or Docker.

With the CLI installer, Ghost will take care of setting up the systemd service, the Nginx config and SSL with a letsencrypt certificate.

I know some people do use Ghost with Docker and Cloudflare successfully, but we also answer more support questions for that setup here because that setup more complex than the CLI installer.