Refused to execute Script error in Chrome Dev tools

After updating my Ghost to v4.24 i got this error in my Chrome Devtools

 **Refused to execute script from 'https://www.mywebsite.com/public/cards.min.js?v=09c95bbaa0' because its MIME type ('text/js') is not executable, and strict MIME type checking is enabled.**

Initially I thought it was due to some changes (PWA) which I made in my theme (Okiro). So i tried changing the theme, but i was still getting the same error on all the themes.

So I performed a rollback to Ghost v4.22 and then the error disappeared. But today morning when
I again updated to v4.25, I started getting the same error.

I have also checked another website running Ghost v4.24 and that website too had this same error.

Is anyone facing the same and has a fix to it?

Hey @delroydsouza! :wave: This has been fixed in Ghost via Fixed MIME type for public/cards.min.js part deux · TryGhost/Ghost@ecbdb22 · GitHub, and will be available in the next release :slightly_smiling_face:

Awesome!! Thanks @daniellockyer