Scheduled Email Newsletter not sending

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

  • What’s your URL? https://blog.sativedigital.com
  • What version of Ghost are you using? 3.22.1
  • How was Ghost installed and configured? Manually running via docker-compose on Digitial Ocean Droplet (not the DO one click one). It’s behind a traefik proxy and using the Lyra theme
  • What Node version, database, OS & browser are you using?
  • What errors or information do you see in the console?

  • What steps could someone else take to reproduce the issue you’re having? See point #3 below

I’m trying out the newsletter functionality and have it configured with mailgun. I have tested the following:

  1. Create a post and publish it immediately, with the email to subscribers option checked for the post-> The post goes live and the emails are sent to subscribers
  2. Create a post and publish it on a schedule, WITHOUT enabling email to subscribers option for the post -> The post goes live at the scheduled time correctly.
  3. Create a post and publish it on a schedule WITH the email to subscribers option checked -> Produced the TIMEOUT ERROR.

The interesting thing is that the emails are sent when the post is published immediately so it is not an issue of email configuration. Also the scheduled post alone is published correctly. It’s only when the scheduled item is an email that caused in an error. There is a message TimeoutError: Timeout awaiting 'request' for 5000ms so I’m guessing it’s something to do with the response time from the mail server that causes the timeout. If yes, is there an easy way to configure this timeout and a quick fix maybe to just increase the timeout period?