Newsletters Not Sending


  • How was Ghost installed and configured? Using 1-Click on Digital Ocean Droplet

  • What Node version, database, OS & browser are you using? Browser is Safari MacOS. Not sure about node version or database.

  • What errors or information do you see in the console? I don’t see any errors. Simply, the transactional emails seem to be working fine, but anything sent as a newsletter seems to just hang.
    In the top left corder of the post it says “Published and sending to 4 members” but nothing ever really happens. I checked Mailgun and it doesn’t look like any information is being sent to them.

Thanks for any help, I appreciate it.

  • What steps could someone else take to reproduce the issue you’re having? I’m not sure at this point. I simply try to send a post to my members but nothing happens.

I don’t know if it’s related, but when Portal started rejecting Gmail address sign-ups, I had to edit the mail settings in the config.production.json file.

I hope that helps.

Hi @ScottSemple thanks for the links.
I’ve gone through and triple checked the config.production.json and updated the port to 465 as one user recommended trying. A few things have changed. I notice now that the transactional emails are now being routed okay through mailgun. But anything post/newsletter related is not.

When I try to send a test email for a post I get this error message:

Screen Shot 2021-02-28 at 7.08.42 PM

So Im not too sure what to try and fix at this point.

Thanks for any and all help here, cheers

After more testing: all of the transactional emails are working fine and route through Mailgun, but no posts/newsletters will send. There aren’t any error messages on the site, nor in the console, nor on mailgun. I’m a stuck on what else to actually check at this point. Anyone have some suggestions?

@brendantko can you share any error logs you are seeing in your Ghost logs?

How many members do you have?

Recently, when we tried to send the newsletter to over 1,000 members, emails were rejected. Root cause was SQLite and we had to move to MariaDB.

I only have 10 so far. Just getting started. So that’s not an issue at the moment unfortunately.

Should I attach the whole error log here or just quote it here in a post?

@brendantko find the relevant errors and share those. Logs are in bunyan format so piping through that if you can will help with the readability

Hi Brendan. Try checking with Mailgun to see if they have a limit on your account. I’ve seen this happen a few times.

Thanks @kevin I will work on getting that sorted out first here.

Thanks @dan I’ll give that a shot too

Just editing my last post. I solved the problem. It was a problem with my API domain and password on Mailgun end. Something got changed on that end that didn’t seem to throw any errors anywhere and I missed seeing the error myself.

So it’s all solved now. Thanks for those who helped out.

1 Like