Slack notification link is broken (404)

#1

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

  • What’s your URL? This is the easiest way for others to debug your issue. Sorry, it’s internal.
  • What version of Ghost are you using? 2.13.1
  • What configuration? Using image docker.io/bitnami/ghost:2.13.1 inside GKE using NodePort service and Ingress.
  • What browser? Google Chrome
  • What errors or information do you see in the console? 404
  • What steps could someone else take to reproduce the issue you’re having?
  1. Setup slack integration in ghost blog admin page.
  2. Write a new story.
  3. Slack notification is received properly.
  4. But, when you click on the link it shows, it’s routing to http://blog.abc.com/404/ previously with version 2.1.1 it used to be http://blog.abc.com/story-1/ and shows the content as intended.
#2

Please upgrade to the latest version of Ghost (Currently 2.19.0). We have made many fixes to URL generation which should resolve your problem.

#3

Thank you. I tried that but receiving below error when the pod is coming up. I am using helm chart, pulling docker image of 2.19.0 and installing in Kubernetes using yaml files.

“message”:“Site is starting up, please wait a moment then retry.”,“stack”:"MaintenanceError: Site is starting up, please wait a moment then retry.\n at new MaintenanceError (/opt/bitnami/ghost/versions/2.19.0/node_modules/ghost-ignition/lib/errors/index.js:142:23)

Can you help with this?

#4

Can you try 2.18.3? We’re investigating an issue with the latest release that might be the cause.

#5

I tried. It’s the same issue.
“stack”:"MaintenanceError: Site is starting up, please wait a moment then retry.\n at new MaintenanceError (/opt/bitnami/ghost/versions/2.18.3/node_modules/ghost-ignition/lib/errors/index.js:142:23)

#6

503 errors are expected when your site is starting, how long did you wait?

#7

I am waiting for more than an hour. It’s definitely not usual. If I use 2.13.1 the service is being brought up in seconds.

#8

Is there any configuration property to create URL links for slack? Because I used old version of 2.13.1 in one environment and that’s working. It’s not working in the other environment. I am wondering what’s different because same docker image is being used.
My primary issue is the link I click on slack is redirecting me to https://ghost.blog.com/404/ instead of https://ghost.blog.com/blog-post-1/

closed #9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.