[SOLVED] Error after update to "1.24.5"


#1

I just ran the update as I’ve always done.

The update was successful.

ghost update
Running sudo command: systemctl is-active ghost _ ****** - it
? Password [hidden]
✔ Checking system Node.js version
✔ Ensuring user is not logged in as a user
✔ Checking if logged in user is directory owner
✔ Checking current folder permissions
✔ Checking folder permissions
✔ Checking file permissions
✔ Checking content folder ownership
✔ Checking memory availability
✔ Checking for available migrations
✔ Checking for latest Ghost version
✔ Downloading and updating Ghost to v1.24.5
Running sudo command: systemctl is-active ghost _ ****** - it
Running sudo command: systemctl stop ghost _ ****** - it
✔ Stopping Ghost
✔ Linking latest Ghost and recording versions
Running sudo command: /var/www/ghost/current/node_modules/.bin/knex-migrator-migrate --init --mgpath / var / www / ghost / current
✔ Running database migrations
Running sudo command: systemctl is-active ghost _ ****** - it
☱ Running database migrations✔ Ensuring user is not logged in as a user
✔ Checking if logged in user is directory owner
✔ Checking current folder permissions
Running sudo command: systemctl is-active ghost _ ****** - it
✔ Validating config
✔ Checking folder permissions
✔ Checking file permissions
✔ Checking content folder ownership
Running sudo command: systemctl start ghost _ ****** - it
✔ Restarting Ghost
✔ Removing old Ghost versions

I tried to access the panel via the link https://domain.com/ghost

There was a message written “There was a problem on the server.” in red at the top, I refreshed the page and the panel became unreachable, only the logo of a ghost is displayed …

The front end is still reachable, for this reason I have not tried to restart ghost yet, I’m afraid the restart will not be successful.

I need urgent help

From console in https://domain.com/ghost:

Https://domain.com/ghost/assets/ghost-dark-75cdc238dcdb36be598bcc7cc1cf0f1e.css' because its MIME type ('text / html') is not a supported stylesheet enabled.
vendor.min-05e679b33815bd84607c2f4d14576051.js: 2664 
Error while processing route: posts.index
error @ vendor.min-05e679b33815bd84607c2f4d14576051.js: 2664

EDIT :

Removing the cache and restarting ghost have solved the problem.
I do not know what it’s due to.

I do not delete anything, maybe it will be useful for someone.

EDIT 2 :

The problem is not solved, after some page refresh I encounter the same error, I can no longer access the admin panel.


#2

@giacomosilli can you share the full error and stack trace from the DevTools console?

Are you using a CDN or other server-side caching/optimisation? If so make sure that /ghost is skipped https://docs.ghost.org/docs/troubleshooting#section-ghost-admin-not-loading


#3

https://pastebin.com/CkGYizQv

I’m using cloudflare.
I’ve added custom page as you said.
link: https://domain.com/ghost
Cache Leve: Bypass
Disable Performance.

Then in “Caching” section -> Purge Everything

The problem is still there, should i have to restart ghost / nginx ?

Thank you


#4

I see rocket-loader.min.js:1 mentioned in the stack trace, rocket loader is a cloudflare optimisation and is known to have some incompatibilities with the admin, are you sure you’ve disabled all Cloudflare optimisations for /ghost?


#5

Solved by change the link from https://domain.com/ghost to domain.com/ghost*

Thank you for help


#6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.