[SOLVED] Intermittent data loss / save failures


#1

Good evening, something really strange is happening.

I wrote a new article, published it, I went to the homepage to see it.
I realized that I forgot the image, came back in the admin panel, uploaded the photo, saved and returned to the homepage, initially the photo was not visible (probably cause was the cache) but the first thing I did is go to check if I had saved correctly. Back in the admin panel I immediately noticed that the article has been deleted. there is only the title of the article, the content is empty, the tag is “draft” and is not published, but in the homepage it is visible with the photo too. I disabled cloudflare and the nginx cache, the post is still there but from admin panel is empty and is not published.

Now if I try to insert new content in the post (published and present on the homepage but in “draft” and not published by admin panel) an error message with the words “Saving failed!” Someone else is editing this post.
But there are no other authors, there is only me, and I have no other open tabs.

I have also exported the contents of my blog, the article exists with all the parameters, including the content, in the json there is everything.
But from the admin panel it is always empty, in draft, and not editable.

Also no errors in console.

Before realizing these problems I also created new tags and inserted the meta data.

I’ve switched to the stories section and then go back to tags and I realize that the tags I’ve created are there, but the meta tags have been deleted. I tried several times to reinsert them but after a while they disappear.

Another strange thing that happens in the tag section is that after the information I have inserted disappears I try to rewrite the title, I click later in the description and the content reappears again. But after I leave the section and come back, this disappears, so:

tag section > insert meta data > switch section > then again tag > meta data disappeared > write meta title > meta description reappears > switch section > then again tag > meta data disappeared .....

I have not yet updated to the latest version 1.24.6

I tried to start ghost doctor, no problems, only the config validation is skipped:

ghost doctor
✔ Checking system Node.js version
✔ Checking logged in user
✔ Ensuring user is not logged in as a user
✔ Checking if logged in user is directory owner
✔ Checking current folder permissions
✔ Checking operating system compatibility
✔ Checking for a MySQL installation
Running sudo command: systemctl is-active ghost_*****
ℹ Validating config [skipped]
✔ Checking folder permissions
✔ Checking file permissions
✔ Checking content folder ownership
✔ Checking memory availability

What could be the problem?

Thank you.


#2

Hey @giacomosilli!

Thanks for sharing so much details.

Are you using the new König Beta Editor (has to be enabled in labs)?
Which Browser are you using?

@Kevin do you have any idea what could cause such a behaviour?


#3

Hi, the article is written using Chrome, I do NOT use the Keoing Editor.

I noticed that using Firefox I correctly see the article and the tags both from admin panel and from homepage.

But now entering with Chrome in the admin panel, the article and the tags have totally disappeared from the list of my articles.

If I use the search in the panel admin i find it, opening the details of the article I also see the tags that I have associated, but if I go in the tags section I can not find them.

Not having problems even using Edge, the problem seems to be just Chrome


#4

Are you using any extensions in Chrome?


#5

Just Wappalyzer and Lighthouse.
It should not be a problem with extensions.
I tried from two different computers in two different places


#6

I can no longer use chrome to manage my blog. It is giving me the following error on all the articles.

“Saving failed!” Someone else is editing this post"

How is it possible?


#7

Well, I really start to worry now.

The problem is now also reflected on firefox.

I modified some old posts, initially I had no problems, after several salvations I received the usual error “Saving failed! …”

Another strange thing, I see the changes on the homepage, but from the admin panel no, it’s as if I had never modified it.

EDIT:
I begin to think that the problem is the Service Worker.


#8

Please name topics properly and assign them to a category. A title of “something strange” with no category is not helpful to anyone who might be able to assist you.


#9

The symptoms you describe point to a caching problem somewhere or trying to run a single Ghost blog across multiple instances. I would check that CF or other caching is completely disabled for /ghost/*

I begin to think that the problem is the Service Worker.

Ghost doesn’t have a Service Worker, is this something that you’ve installed yourself? If so it will definitely interfere with the admin if it’s not configured correctly to let all API requests pass through.


#10

Thanks for the reply,
it’s definitely a problem caused by the service worker.
I installed it myself, I have to understand how to configure it.


#11

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.