[SOLVED] Unable to upgrade Ghost from v4.4.0 to v4.5.0

Hi Guys,

I’ve tried to update my ghost blog (v4.4.0 + Sqlite3) to the last release (4.5.0) but nothing happens.
Did I miss something ? :thinking:

PS : I didn’t try to force ghost update

OS: Ubuntu, v20.04
Node Version: v14.17.0
Ghost-CLI version: 1.17.2
Ghost version : 4.4.0
Database : Sqlite3
>ghost update
+ sudo systemctl is-active ghost_xxxxxxx
✔ Checking system Node.js version - found v14.17.0
✔ Ensuring user is not logged in as ghost user
✔ Checking if logged in user is directory owner
✔ Checking current folder permissions
✔ Checking folder permissions
✔ Checking file permissions
✔ Checking content folder ownership
✔ Checking memory availability
✔ Checking free space
✔ Checking for available migrations
✔ Checking for latest Ghost version
All up to date!

Thank you for your help.

Has v4.5.0 been released yet? I just did a fresh install and I’m still getting v4.4.0. Does Ghost automatically install the latest version? Can you link me to a page that talks about v4.5.0?

Releases are described here:

You need to upgrade manually:

1 Like

4.5.0 is not available so you won’t be able to upgrade to it. The release was pulled after initial post-release testing indicated that some features weren’t ready for prime-time.

The latest installable version is always visible the “Versions” tab here https://www.npmjs.com/package/ghost


Yes, I just attempted upgrading and got this message:

“You are trying to install Ghost v4.5.0, which has been deprecated with the following notice: “Ghost 4.5.0 contains some inconsistencies in the UI when configuring member functionality. These will be fixed in the next release to make sure that our users continue to have a good experience.”
Help: Either pick a different version to install, or re-run with --force to install anyways.”


My bad !
Thank you very much :slight_smile:

I have installed 4.5.0 and I am using it, shall I downgrade, or wait for a fix and upgrade?