Subscribe and login button not working

I am currently self hosting and using the Dawn theme. For some reason the “Subscribe” “Login” or “Sign Up” buttons work. You click them and they don’t do anything. I have portal enabled, and I also have mailgun domain and api key entered into the settings. One other thing that I have noticed is that if you go to any of my blog posts, at the buttom where the “comments” are it is just a loading wheel. I do not know if these issues are related or not. The website is if you’d like to check out the issue. Any help would be greatly appreciated. Thank you!

Try with browser developer tools open and check the Network and Console tabs when you make those clicks.

Looks like your URL is configured as instead of (https)

1 Like

the browser developer tools doesn’t work for me either. I’ve tried on multiple browsers

how do i change it to https? I don’t see any options within the ghost admin panel to do so.

How did you install Ghost? Assuming you used the Ghost CLI, you’ll need to use it to update the URL:

cd /path/to/ghost
ghost config set URL
ghost restart
1 Like

I used docker and Portainer. I ran the commands inside the container and it successfully changed the URL. However the buttons are still not working.

In that case you need to update the environment variable. Be sure to restart the container after making any changes.

1 Like

I am not quite sure how to do that. Would you be able to explain? Thank you

Can you post your setup in Portainer here (make sure to remove any secrets), so we can have a look?


How to set Ghost config values as environment variables is documented here:


Start Ghost using environment variables which match the name and case of each config option. For nested config options, separate with two underscores.

So the environment variable you’d need would be called simply URL.

There seems to be a tab in Portainer’s UI to set environment variables.

i modified the config.development.json and the config.production.json URL to say I then restarted the service and it didn’t fix anything.

There are a number of factors why that can happen in your setup – the most likely being that these files aren’t persisted on a volume.

I am running Ghost instances in Docker and Portainer myself, but each setup is different. As mentioned, would be great if you could just show us how your setup looks like, in order for us to help you for your specific case, rather than poking into the dark :slight_smile:

just posted it above!

Just saw your other post with the screenshot.

You can see all the ENV (environment variables) you have right there. There is one called url that is overwriting the stuff you have in the config.jsons. Go to the editor of your stack in portainer (Stack → select the stack you’re editing and change it there). This is where you’ll need to change the URL.

There is no ghost stack in my portainer. Its only in the container section. I had to recreate the container, but it’s working now! thank you!

1 Like

Awesome! Glad you found it!

1 Like

FYI – I installed a script to enable a shopping cart service, and it broke the portal. Click the links, nothing happened.

I didn’t explore for long as to why it happened; just deleted the script and all worked again. Very strange.

Since the shopping cart script involved a fly-out screen, perhaps it blocked the portal. But, it’s gone now.