Theme errors after update to 5.56

After updating to 5.56 i got this error
" * [

Unknown global helper used


A global helper was detected that is not supported by this version of Ghost. Check the helpers documentation for further information.

Affected files:
  • page.hbs: {{@page.show_title_and_feature_image}} is not a known global"

Hey @Arledia , welcome to the forum!

So that helper is brand new. (And it’s going to do cool new stuff!) It was supposed to be released today. I’m guessing something has gone slightly wrong, since the message above would indicate that the helper is present in the theme you’re trying to install, but apparently the Ghost core is not ready for it yet.

Which theme are you trying to install?
What method did you use for installing/upgrading Ghost, if not on Ghost Pro?

@Cathy_Sarisky I have the same issue. I’m using Casper theme, self-hosted. What, if anything, should I do?

latest Casper theme, self-hosted.

If you’re comfortable with Git, I’d say checkout a slightly earlier version. Or remove everything within the if statement from page.hbs

any instruction to downgrade the Ghost update?

It’s possible to downgrade using the ghost-cli (assuming that’s how you installed), but I don’t see an obvious way to downgrade the theme beyond choosing an earlier version from github.

Actually, are you running Casper? I think downgrading the core will downgrade Casper also. (Not 100% sure, but Casper is special, so maybe.) Ghost-CLI - A fully loaded tool for installation and configuration

ghost update --rollback

(Should take you to the previous version you had installed)
Then followed by

ghost update 5.55.2 --force

If you weren’t already at that version and want to get to a recent (not broken) version.

Interesting point of information for self-hosters: Ghost Pro seems to be at 5.55.2 still, or at least my Ghost Pro site does. You may want to wait on doing a generic upgrade until the reported issue with 5.56 is resolved, or use the command above to only upgrade to 5.55.2…

Hi! I received this error message as well. There are other error messages with my purchased theme. So it’s not specific to the Casper theme. Everything was working with 5.52 on Thursday. I ran and update on Saturday and everything broke.

Hi all! Thanks for the reports on this.

As mentioned, the error message is related to an upcoming feature release and how the CLI installs Ghost and Casper. That means that only users who use Casper and update/install via the CLI will be affected. We’re currently investigating the issue and will push a fix when resolved.

This error won’t cause your site or Casper to stop working.

I’ll update this thread with additional updates as they become available. Please let me know if there are additional questions.

Update: The issue has been identified and a fix has been written. We’re currently working on creating a release. The issue turned out to be more complex than expected (it always is, isn’t it?), so thank you to everyone who posted about this. We wouldn’t have been able to chase down this bug without your help! I’ll post another update once the patch goes live, but updates/rollouts going out this week should fix this issue. If you continue to see the problem, please post a message in this thread.

Update: This issue has been resolved in the latest release: Releases · TryGhost/Ghost · GitHub

1 Like

Problem solved! Updated to the latest release. Thanks for the great support.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.