Tried to transfer posts from Substack multiple times, recieve the completed email but don't see the posts

So I have tried to follow the instructions for transferring posts AND specifically the Substack transfer tool, received the completed emails, and yet none of the posts are under the account. Am I missing a step that isn’t listed out in the documentation? Is there a hang up on the back end I don’t know about?

Many import tools create the posts as drafts, so you wouldn’t immediately see them on the front page of the site. Did you look in /ghost under the ‘posts’ tab to see if they’re there?

Yeah that was the first place I checked but I didn’t see any drafts, published, or scheduled posts of those I transferred over.

That’s weird. If you’re on Ghost Pro, you might want to email them. If you’re self hosting, you might want to check your Ghost logs for errors.

Are ghost logs and history [in setting[ the same thing? If so I don’t see any errors.

No. Where are you hosted?

No, the history in settings is more “high level” and rather meant for what auditing what’s happening in Ghost (think big publications with multiple authors, editors, etc.).

If you’re self-hosting, you will find the Ghost logs by running ghost log in the directory you’ve installed Ghost in, or by referring to the actual log files mentioned in here:

If you’re on Ghost(Pro) or a different managed Ghost hosting provider, you’ve got to email them, as has been pointed out.

Its hosted on ghost.org but not as ghost pro.
https://dm-dalliance.ghost.io/

If your domain ends in .ghost.io you’re hosted on Ghost(Pro), the Ghost Foundation’s hosting service.

Send them an email to support@ghost.org – most likely, they can help a lot better than us, since they should have access to your logs.

Quick update:

One of my customers at Magic Pages has just reported an issue that sounds a lot like what you are experiencing. After using the Substack transfer tool no posts show up at all.

This is what I found in the logs:

[2024-01-03 07:59:47] ERROR "POST /ghost/api/admin/db" 500 90ms
An unexpected error occurred, please try again.
0=C 1=a 2=n 3=n 4=o 5=t 6=  7=r 8=e 9=a 10=d 11=  12=p 13=r 14=o 15=p 16=e 17=r 18=t 19=i 20=e 21=s 22=  23=o 24=f 25=  26=u 27=n 28=d 29=e 30=f 31=i 32=n 33=e 34=d 35=  36=( 37=r 38=e 39=a 40=d 41=i 42=n 43=g 44=  45=' 46=s 47=p 48=l 49=i 50=t 51=' 52=) 
Error ID:
    108e0130-aa0e-11ee-b631-15514022267a
Error Code: 
    UNEXPECTED_ERROR
----------------------------------------
TypeError: Cannot read properties of undefined (reading 'split')
    at module.exports.prepareError (/var/www/ghost/versions/5.75.1/node_modules/@tryghost/mw-error-handler/lib/mw-error-handler.js:102:19)
    at ImporterContentFileHandler.loadFile (/var/www/ghost/versions/5.75.1/node_modules/@tryghost/importer-handler-content-files/lib/ImporterContentFileHandler.js:48:82)
    at ImportManager.processZip (/var/www/ghost/versions/5.75.1/core/server/data/importer/import-manager.js:318:44)
    at async ImportManager.importFromFile (/var/www/ghost/versions/5.75.1/core/server/data/importer/import-manager.js:491:26)
    at async Http (/var/www/ghost/versions/5.75.1/node_modules/@tryghost/api-framework/lib/http.js:64:28)

At first glance, this sounds like an issue in the Substack data (e.g. a missing field on a post or something like that). I will have a look at the implementation of the transfer tool later today to see what could be the issue.

I’ve just pushed a fix to these tools that filters out empty tags, which I believe caused this error. Let me know if it now works or if you encounter any other errors!

4 Likes

Even after this update, the Substack importer simply fails to work for me. It keeps saying the posts have been imported every time but none are!