Twitter & youtube cards not showing correctly in email

Today I’m testing out the members email feature. The only problem I’ve noticed is that my twitter cards from embedded tweets aren’t showing up correctly in the email after sending a test email. In the editor they look fine.

This is the test email I sent: tweet showing incorrectly and no youtube embed

This is the browser preview in the editor:
(also the youtube embed looks weird here too?)

1 Like

Temporary workaround is to specify everything as a bookmark instead of the native embedding that the ghost editor does. Still not the look I’m going after though

1 Like

Here’s what works for me (i am doing a blog post tutorial since i had the same issue hehe):

  1. Instead of embedding the video via link, use the embed generator in YouTube and paste the code in a HTML card.

For some reason, when you do it the regular way, the videos/cards aren’t centered in the format. When you embed the code, then it works. Maybe there’s a bug and we raising the flag will make the team solve it.

Hope it helps.

Hey thanks for the reply. I’ve tried that and it seems to still not show up in the email but now it shows up in the attachments section. I’ll keep messing with it and see what happens. So far, putting every link as a bookmark seems like the best way to ensure the format doesn’t fall apart

1 Like

Interesting.

Another thing that i found is, that Gmail online doesnt show them (im not sure the reason). If you use gmail but use another app more developed (like Spark), it does show up.

Have you tried seeing the mail using another app?

hah that’s funny, google not showing their own stuff in the inbox. I haven’t looked at anything else but I’ll check it out

Indeed haha!

This is a known limitation of the beta - we’re definitely planning to work on it, but as you’ve already identified here - email clients can be a bit weird about what they do/don’t allow in terms of rich content :no_mouth:

3 Likes