Using Cloudflare with Ghost hosted on DigitalOcean


I have a blog hosted with Digital Ocean. Currently, only the DNS is set to proxied in Cloudflare but if I set it to “proxied” then the website does not work with an error about “too many redirects”.

Has anyone faced this issue? I’m sure there is something I’m doing wrong but not sure what that is.

try Make the SSL Flexible from cloudflare SSL Tab…

The solution that worked was to use “Full (strict)” for the SSL option.

I found a good article about this on