Upgrade 3.22 issues

Hello,

Hoping someone can help, since upgrading to 3.22.1 all of my members and publication info disappeared.

I have managed to populate this all again, but am unable to select any Subscription pricing. This area just shows an empty box under Plan currency and nothing help.

Upgraded to 3.22.2 this morning and having same issues.

Would you be able to share your members/stripe settings with us so we can help debug?

If you connect to your database and run select * from settings; it’ll output all of your settings, and you can copy any members/stripe specific ones.

Please make sure you don’t copy any secret key or secret token values though!

It would also be useful if you can share any Ghost server & console logs, and how you upgraded :slight_smile:

Unfortunately I have no idea how to do that.

Okay, no worries, if you are able to look in the directory you have Ghost installed in, you should see a folder called content and inside there another folder called data.

That data folder contains a lot of json files which are backups or your database before each upgrade.

If you would be able to open the most recent of those files and search for members_subscription_settings you should see something like:

{"id":"5efaf1c15c998f66156e5ff9","key":"members_subscription_settings","value":"{\"isP      aid\":false,\"fromAddress\":\"noreply\",\"allowSelfSignup\":true,\"paymentProcessors\":[{\"adapter\":\"stripe\",\"config\":{      \"secret_token\":\"\",\"public_token\":\"\",\"product\":{\"name\":\"Ghost Subscription\"},\"plans\":[{\"name\":\"Monthly\",\      "currency\":\"usd\",\"interval\":\"month\",\"amount\":\"\"},{\"name\":\"Yearly\",\"currency\":\"usd\",\"interval\":\"year\",      \"amount\":\"\"}]}}]}","type":"members","created_at":"2020-06-30 08:03:13","created_by":"1","updated_at":"2020-06-30 08:03:1      3","updated_by":"1"}

If you would be able to copy that, and remove the bits which have the secret_token, and paste that here, we will be able to work out what’s causing this issue and make a fix for it

Thanks @fabien I think I have done this correctly.

{"id":"5e4244a81dffc969608a45b8","key":"members_subscription_settings","value":"{\"isPaid\":false,\"fromAddress\":\"************\",\"allowSelfSignup\":true,\"paymentProcessors\":[{\"adapter\":\"stripe\",\"config\":{\"secret_token\":\"sk_live_*********************\",\"public_token\":\"pk_live_***********************\",\"product\":{\"name\":\"Greg Morris\"},\"plans\":[{\"name\":\"Monthly\",\"currency\":\"gbp\",\"interval\":\"month\",\"amount\":300},{\"name\":\"Yearly\",\"currency\":\"gbp\",\"interval\":\"year\",\"amount\":2000},{\"name\":\"Complimentary\",\"currency\":\"eur\",\"interval\":\"year\",\"amount\":\"0\"},{\"name\":\"Complimentary\",\"currency\":\"gbp\",\"interval\":\"year\",\"amount\":\"0\"}],\"currency\":\"gbp\"}}]}","type":"members","created_at":"2020-01-17T17:08:55.000Z","created_by":"1","updated_at":"2020-04-03T07:46:59.000Z","updated_by":"1"}

Thanks! That was helpful :slight_smile:

We’ve managed to reproduce this issue by upgrading to 3.22.0, trying to save members settings and then upgrading to 3.22.2

I would suggest that you rollback to 3.21.1, and restore your data from your backup.

From here you should be able to upgrade directly to 3.22.2 - totally skipping 3.22.0 - and you should be in a good state!

Ok, I will try and do this - any good guides out there to help?

I have tried ghost update 3.21.1 --force

and get the following error
:heavy_multiplication_x: Checking for latest Ghost version
A CliError occurred.

Message: The custom version specified: 3.21.1, is less than the current active version: 3.22.2

Debug Information:
    OS: Ubuntu, v18.04.4 LTS
    Node Version: v10.21.0
    Ghost Version: 3.22.2
    Ghost-CLI Version: 1.14.1
    Environment: production
    Command: 'ghost update 3.21.1 --force'

Just to double check. I run sites using 3.21.0.
Therefore, I should upgrade directly to 3.22.2 right?

Thank you!

The docs for Ghost-CLI are here: https://ghost.org/docs/api/v3/ghost-cli/

I think you’ll want to run:

ghost update --rollback

:relaxed: Let me know how it goes!

That’s right @pascalandy - for more info check out this GH issue: https://github.com/TryGhost/Ghost/issues/12020

Thanks!

Thanks

I rolled back to a snapshot on Digital Ocean because I couldn’t fix this.

Made the mistake of upgrading to 3.23.1 this morning and I am now unable to change any settings with the following error:
Permission error, cannot edit setting. Attempted to access core setting from external request

Hi all! :wave:

We just released 3.24.0, which fixes this issue. Please update using Ghost-CLI :slightly_smiling_face: