Visual Bookmark Not Working in Editor

I am having issues with the Visual Bookmark feature. When uploading a link via the Bookmark input, I get an error as below:

Additionally, when I paste the link directly in the editor, it used to produce the visual bookmark automatically, now it simply shows the link.

Nothing registers in the console when I try and add a bookmark. The links I have used definitely have “bookmark” tags as when I post them on Twitter and the like, they have no issues.

I run Ghost v4.12.1 on a self-hosted Digital Ocean droplet.

Anyone else run into this?

Hey!

Could you please let us know what link you are trying to paste into the editor?

So I can see if I can replicate the issue in my Ghost instance.

I haven’t found a single link that actually works.

But because you asked: ‘Our Menu Is Very Darwinian.’ Leading McDonald’s in 2021. - The New York Times

When I paste the link, it doesn’t turn it into a bookmark as you said.

But when I click /, select ‘Bookmark’ from the menu and paste your NYT link, I hit Enter and then it turns it into a visual bookmark - see gif below:

Screen Recording 2021-08-27 at 09.24.07

I’m also on DigitalOcean:

  • Version 4.11.0
  • Environment production
  • Database mysql
  • Mail SMTP

Mine still does not work when using the dropdown visual book mark selection. It shows the same error as in the original post. There are no other errors in the console either…