Vultr install Install problems

I am not a super advanced user, but this installation on Vultr is error after error. It feels like You can install but it’s just easier to go with ghost pro…

Does anyone know what going on?

:heavy_check_mark: Finishing install process

? Enter your blog URL: http://localhost:2368

? Enter your MySQL hostname: localhost

? Enter your MySQL username: root

? Enter your MySQL password: [hidden]

? Enter your Ghost database name: ghost_prod

:heavy_check_mark: Configuring Ghost

:heavy_check_mark: Setting up instance

  • sudo chown -R ghost:ghost /var/www/ghost/content

:heavy_check_mark: Setting up “ghost” system user

? Do you wish to set up “ghost” mysql user? Yes

:heavy_multiplication_x: Setting up “ghost” mysql user

Your url contains a port. Skipping Nginx setup.

:information_source: Setting up Nginx [skipped]

Nginx setup task was skipped, skipping SSL setup

:information_source: Setting up SSL [skipped]

? Do you wish to set up Systemd? Yes

  • sudo mv /tmp/localhost/ghost_localhost.service /lib/systemd/system/ghost_localhost.service

  • sudo systemctl daemon-reload

:heavy_check_mark: Setting up Systemd

  • sudo systemctl is-active ghost_localhost

? Do you want to start Ghost? No

:information_source: Starting Ghost [skipped]

One or more errors occurred.

  1. ConfigError

Error detected in the production configuration.

Message: connect ECONNREFUSED ::1:3306

Configuration Key(s): / database.connection.port

Current Value(s): localhost / 3306

Help: Ensure that MySQL is installed and reachable. You can always re-run ghost setup to try again.

Very very annoying

The error says that your MySQL database isn’t available.

Did you set that up properly and is it running?

Yes. at least 25 times… I change many configs and use chat to assit

The problem is that I am in sao paulo brazil, and a droplet does not run well here, and I need to have bigger servers. Vultr has a server here.

So there is not much option here. unless i go to gcp or aws

But ghost setup (or ghost install) doesn’t set up your MySQL server and database.

So, the question remains: did you set that part up?

As in, you ran sudo apt-get install mysql-server, then set up your MySQL user and database?

If you did, make sure the server is running.

Yes i followed the exact guide on ghost and tried som others. I get permission problems, then fixed, then i get squel problems.

I bet if i make a bigger server, it will work… I am starting to see ghost doesn’t like the small server much

I ran the server and half the time it crashed the instance

might me just me but I am not doing rocket science here.

What is the return of sudo service mysql status?

I deleted the server now as I could spend a week of time to fiddle with a little probelm to save 4 bucks. too much time… just opened a droplet

1 vCPU
2GB / 50GB Disk

The smaller one presents problem after problem and crashes… the internet in Brazil is the worst and we have non stop problems here

Alright. Best of luck with the server then :+1:

Thanks… Cheers