When I try to upload a publication icon or a publication logo to my site, it gives me a spinny wheel

I’m on Mac so I don’t really know if that is the reason for anything or WHAT is going on to be honest. is this happening for anyone else?

Well, it shouldn’t do that! But we need much more information about your site to be able to help. Where are you hosting? How did you install Ghost? How big is the file you’re trying to upload? Do you have a proxy in front of your Ghost site that might be blocking things? If you check the console logs for your page (hit f12 to open dev tools and click the ‘console’ button), is there an informative error message?

Ghost won’t even let me click on the file I’m trying to upload. When I click it, a spinning wait cursor is popping up. after the wheel goes away, nothing happens. It’s a very small file. I’m using ghost on safari, so that’s maybe the problem. I don’t have any kind of proxy blocking ghost either. Finally, I’m not sure hot to check the console logs since I’m on Mac. Thanks!

Yeah, so it shouldn’t do that. People do successfully use Safari with Ghost. :)

If you want to check the console logs, here’s a link: Help And Training Community

You could try another browser to see if the problem goes away, or try updating your current version of Safari if you haven’t done so recently. (Does Safari on Mac auto-update? No clue, I’m a Windows/WSL2 gal.)

Do you have any browser security software/pop-up or ad blockers installed that might be interfering? You might trying turning them off temporarily and trying again.

I do have an adblocker I did turn it off in case that was the problem. When I check the console logs there is no error message that pops up so I don’t know if that is a good sign or bas sign lol. Safari does auto update but I can see if there are any other ones.

I guess you could call this kind of an update, but I tried to upload a publication icon/logo and it still didn’t work :(

Hopefully some Mac users will have some suggestions for you! :) Or you could install Chrome and see if that lets you continue with your work with Ghost in the meanwhile.

sorry I think autocorrect messed up what I said. What I meant to say was I tried to upload an icon on chrome and it didn’t work.

I’m going to PM you - maybe we can have you try my test site and see if you can upload there, which will suggest a problem with your ghost install. Or if that also doesn’t work, then you’ll know it’s related to your computer/browser/file/internet access.

Update for any Mac users reading - the problem is NOT unique to whoisbud’s install (it also happens on my demo site), so we could probably use some Mac user advice on what to do with this problem. Any ideas?


Interesting and looking forward to replies from Mac users.

I use Safari on iPad for all my work with Ghost Pro (newby alert, sorry) and it’s all fine and dandy (one of the reasons I chose to ‘learn’ Ghost for my blog). For example on Ghost Pro, I have no trouble downloading and uploading anything, including not just images and other ‘Card’ content, but edited theme and Yaml files.

Obviously iPadOS is not the same as MacOS and accessing Ghost Pro can be a different experience to using Ghost served on a Mac local host or on a droplet, or whatever, accessed using a Mac :roll_eyes:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.