Your connection is not private

Hey everyone, Please can someone help me out with error, I am using mailgun and everything was very well, but lately I starting this error, is a new user want to sign up they do experience this error also, and my users can not view their email in the browser, Please can anyone help out? Thanks

Why are you attempting to connect to this address using HTTP? It’s not intended to be used this way; the subdomain is for Mailgun tracking only.

Typically, you’ll have MX records for the bare domain plus MX records for Mailgun, e.g.,, and optionally a CNAME for tracking, e.g.,

It would seem that you have misconfigured Ghost if one of these is hyperlinked in an email. Therefore, please share your config and newsletter settings.

(post deleted by author)

Yikes! Those look like real credentials. You’ll need to change those – immediately!

No, the there are not real, I did change them before putting online

1 Like

Hey cassyblaise, please follow this steps.
Go to settings and click on privacy after clicking the privacy there will be tracking prevention there you’ll have to choose standard option, definitely your problem will solve.
Thank you.

Hey nehakakar, please if I may understand you clearly, do you mean google chrome setting?

Ohh that is for edge browser, for chrome go to setting and click on privacy and security after that go to safe browsing then choose standard protection.

yes but follow second one

Thanks for your time and respond, I know this can be fix through the privacy at the browser, but how about my users and the people that are using the blog, not everyone will have the knowledge of fixing this error from their browser, some may just leave the site out of frustration and never visit it again.

I’m sorry but I was facing the same issue, so I suggest to you. Did I something wrong here, please answer me.

No, I did not said you did anything wrong. what am try to say is, it is not everyone that is using the website will have the will have the knowledge of fixing this error from their browser.
Btw, I am not saying your answer is wrong.

Okay. I understood that.

1 Like

Your config isn’t set up correctly for using Mailgun for transactional email. Indeed, attempting to sign-up fails to send the magic link.

Moreover, this method is not used for sending bulk email, i.e., newsletters, which will utilize CNAME. Can you please share the newsletter config, and also explain how you landed on the URL?

@mjw I have reached out to mailgun support, they have fix the errors for me, and everything is working fine now. Thanks a lot for your time, I truly appreciate it.

It would be really helpful if you shared the detail since the underlying cause and resolution isn’t evident.

1 Like

Ok, I honestly do not know how to explain this but I will try my best. I do not if the method I used in setting up the newsletter config is wrong or something but I was following this instructions from this YouTube channel( ) and everything workout fine, but early this month I notice this error “Your connection is not private” I tried to fixed it but nothing workout, so that was when I reached out for help here in this forum and also the mailgun support team. and this was this reply I got from them:
“Thank you for contacting Sinch Mailgun Support. I noticed that the Certificate was not up. I went ahead and manually generated the certificate for and confirmed it is secure now.”

So, basically I think, the issue was SSL Certificate was not up or it has expired.

I am sorry for the long note, but I hope this will help out a bit, Thanks :pray:

Btw @mjw Please, if you have a better solution on how to Set up the newsletter config, Please I don’t mind you can share it with us, Thanks.

I can see that the URL now returns an HTTP 404 error, and the certificate is valid. However, what isn’t clear is why you visited the link, and why it was an issue for you. The URL is for tracking, and this is achieved using a 1px image in the body of a newsletter email.

Moreover, I note that sign-up to your site still fails: Failed to send magic link email. As pointed out earlier, your transactional mail setup has errors.

I did not visit the link per say, I emailed my the article from ghostcms, and once I click view online from my inbox it was redirected to my browser, that was when I notice the wrong.