Issue with emails

the issue is that newsletter emails will not send. we have all the DNS records properly configured in mailgun and yet the emails will not send. we also have the mailgun api properly configured in ghost.

here’s some more info:

Please help! Thank you

Your DNS is not set up correctly. You have both Google and Mailgun MX on the bare domain. I’m afraid that’s not right: Mailgun should be on a subdomain, e.g.,

1 Like

The hostname is incorrect: it’s the bare domain. You’re already using this with Google Mail, so it needs to be on a subdomain, e.g.,

1 Like

thanks @mjw . so should i just used or what should i use? I’m sorry but I don’t know what to put there instead.

Use for MX, as you may want to set up a CNAME for later. Furthermore, make sure you log into Mailgun and change the domain settings, and confirm that these are reflected in the settings.

Thanks so much, @mjw . These are my updated records in Digital Ocean:

everything seems to be ok in mailgun:

You need to remove the incorrect records, too. Mailgun is seeing these rather than the new ones.

Also, be patient since it may take a few hours for the changes to propagate.

sorry @mjw do you know which ones in particular are incorrect?

I can’t be much clearer. You should have two MX records pointing to Mailgun, and these need to be named So, remove the other four, but not those related to Google Mail.

Thank you @mjw

I did that and now Mailgun is showing “unverified”

are you sure it should be the It was showing verified before i removed the additional records :scream:

here is the screenshot of the updated records!

scratch that – looks like it finally registered/ it’s working!

1 Like

It was showing verification for the bare domain, but this wouldn’t work because you already use the bare domain for Google Mail.

Therefore, this is correct.

DNS propagation takes a while.

Now test your mail using the API and SMTP.