Can't enable my Ghost Droplet anymore


I tried to update my Ghost install and then one thing led to another. I don’t know what happened.

This is the latest situation:

My blog is at, I have the following ‘specs’ - 1 GB Memory / 25 GB Disk / SGP1 - Ghost on Ubuntu 18.04

I am trying to update to latest Ghost version (seems done) but how to re-activate my blog now?

I recently tried to update my Ghost blog and the update failed like this. Can you post the error log? It will have some information about the issue.


I couldnt access the log though. how to do so?

The log file is under <ghost_root_dir>/content/logs. Have you tried to manually restart ghost using ghost start command?

I tried Ghost Run


and Ghost Log


Seems the port 2368 is already being usied. So u need to kill the process of port 2368 & then try starting ghost …
It should work

1 Like

I tried stopping through “Ghost Stop”

but were you referring to another method ?

Get the process ID by running the following command

lsof -i :2368

& Then kill the process by following command … replace the number with actual process id you got from above command.

kill -9 12345

If you got permission error on above commands then add sudo before the command