Ghost admin page not working on local installation


#1

Im working on a site locally that had no issues previously for a few days during development but after running the yarn dev command, my admin page for some reason stopped working. The front end blog portion is unaffected and works as intended. On the admin side I have no browser errors except several 404 logs complaining about missing static files. Running ghost doctor doesn’t have any clues either. Im starting to think this could be some weird npm or yarn issue. I’ve deleted and reinstalled my node_modules folder but nothing…

I tried this advice but none of that worked for me.

  • What version of Ghost are you using?
    Ghost-CLI version: 1.9.8
    Ghost version: 2.9.1

  • What configuration?
    Local | MacOs 10.13

  • What browser?
    Chrome 72.0.3626.119

  • What errors or information do you see in the console?
    404: files not found (css/js)

  • What steps could someone else take to reproduce the issue you’re having?
    run yarn dev


#2

Ghost-CLI doesn’t set up a core development install so grunt dev is not expected to work. If you want a core development install you’ll need to follow the relevant setup instructions:


closed #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.