How to add ISSO Comments to Ghost?


#1

I have successfully installed ISSO comment server (using their Docker build) on my Ghost blog server.

My Ghost blog: dev.mydomain.com
ISSO server: dev-comments.mydomain.com

After confirming these two servers are up and running…

I must insert the ISSO script in the Ghost theme for it to run on the blog. Following instructions from here

Next, edit the post.hbs file and remove all code inside the <section class="post-full-comments"> section since this is code for Disqus. We need to replace it with the ISSO client script:

<section class="post-full-comments">
    <script
      data-isso="http://dev-comments.mydomain.com/"
      data-isso-lang="en"
      data-isso-vote="false"
      src="//dev-comments.mydomain.com/js/embed.min.js"></script>
    <section id="isso-thread"></section>
</section>

I am modifying the file /var/www/ghost/current/content/themes/casper/post.hbs with the above code replacing with the actual hostnames but I’m not seeing the comments in the post pages.

What could be missing/ wrong here?


#2

Restart your ghost blog and check

ghost restart

#3

@mskian yes I did restart ghost after making the changes to post.hbs.

All I’m seeing is a message at the bottom of blog posts that says “We we’re unable to load Disqus. If your are a moderator please see our troubleshooting guide.”


#4

using Disqus? or isso? remove the previous comment system and add this


#5

I made changes to add the isso script and update like below. Then I did a ghost restart, cleared cache from browser but not seeing the isso comments there.

<section class="post-full-comments">
    <script
      data-isso="http://dev-comments.mydomain.com/"
      data-isso-lang="en"
      data-isso-vote="false"
      src="//dev-comments.mydomain.com/js/embed.min.js"></script>
    <section id="isso-thread"></section>
</section>

I’m modifying the following file, which I think is the right one.

/var/www/ghost/current/content/themes/casper/post.hbs


#6

People could help if you would share the actual address of your site :-p.

http://dev-comments.mydomain.com/


#7

@pascalandy of course! Still new at asking questions here :slight_smile:

The blog is at dev-us.theislandproject.co

The ISSO comments server running at
dev-comments.theislandproject.co

Note: I have never enabled any kind of comment system on this blog.
Yesterday, I commented out a line that referred to Disqus in the post.hbs file under /var/www/ghost/content/themes/storymagtheme/post.hbs. This is different from the post.hbs in /var/www/ghost/current/content/theme/Casper/

Thank you!


#8

What I would do is to insert Disqus comments just to see if it works. Then, I would try ISSO.


#9

Thanks @pascalandy. I begrudgingly started integrating Disqus and in doing so I uncovered the root of this problem.

  1. I’m not using the default Casper theme. I’m using a customized off-the-shelf Ghost theme (not realizing the non-trivial differences in how the code is spread across post.hbs and partials/*.hbs. Casper theme post.hbs includes comment logic and my theme doesn’t)
  2. The above resulted in me modifying the wrong files to inject the ISSO and Disqus scripts (the /var/www/ghost/current is not the correct folder - ever, to modify the themes, it should always be /var/www/ghost/content/themes/mycustomtheme/post.hbs or one of the files within the partials folder)

I modified the correct file, in my case, this is under partials/disqus.hbs (this is used by the post.hbs).
At this point, Disqus was working, and now ISSO is also working on dev-us.theislandproject.co.

Thanks for your help!


#10

Glad it worked!


closed #11

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.