Issues with Ghost CMS and Cloudflare - Web Server Down Error

I fellow installtion Debian
I’m currently experiencing issues with my Ghost CMS site, which is protected by Cloudflare. My site displays a web server error, and I’m looking for assistance to resolve this problem. Here are the details and the troubleshooting steps I’ve followed so far:
Problem Description:

Linux v2202406227393275735 6.1.0-21-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.90-1 (2024-05-03) x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Fri Jun 28 10:24:43 2024 from 41.97.49.87

My Ghost CMS site shows a web server error when I try to visit it. Cloudflare displays an error message indicating that the web server is down.

errors_message

website utl: quikseekr.com

show web server error down

Turn off Cloudflare proxying. (Set to DNS only.)

If you’re on Ghost Pro, check that your custom domain is activated. Re-add it if not.

Not working

Désolé, impossible d’accéder à cette page.quikseekr.com a refusé la connexion.
Essayez :

Vérification de la connexion
Vérification du proxy et du pare-feu
ERR_CONNECTION_REFUSED

If Cloudflare reports that your host is down, I would try having a look at your server.

Looking at ghost ls just shows whether ghost is running, but not whether your server is a) hooked up to the internet and b) exposing Ghost.

Is nginx running on your server? What port is it exposing your Ghost instance on?


Love open source? We’re hiring JavaScript Engineers to work on Ghost full-time.
https://careers.ghost.org

┌────────────────────────────────────────────────────────────────────────────┐
│Warning: MySQL 8 will be the required database in the next major release of │
│                                  Ghost.                                    │
│  Make sure your database is up to date to ensure forwards compatibility.   │
└────────────────────────────────────────────────────────────────────────────┘

+ sudo systemctl is-active ghost_quikseekr-com
┌───────────────┬──────────┬─────────┬──────────────────────┬───────────────────────┬──────┬─────────────────┐
│ Name          │ Location │ Version │ Status               │ URL                   │ Port │ Process Manager │
├───────────────┼──────────┼─────────┼──────────────────────┼───────────────────────┼──────┼─────────────────┤
│ quikseekr-com │ ~        │ 5.86.2  │ running (production) │ https://quikseekr.com │ 2368 │ systemd         │

But that’s exactly the same output as before from ghost ls.

What about nginx?

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Fri Jun 28 11:28:52 2024 from 41.97.49.87
ghostadmin@v2202406227393275735:~$ ^[[200~systemctl status nginx~
-bash: $'\E[200~systemctl': Kommando nicht gefunden.
ghostadmin@v2202406227393275735:~$ systemctl status nginx
● nginx.service - A high performance web server and a reverse proxy server
     Loaded: loaded (/lib/systemd/system/nginx.service; enabled; preset: enable>
     Active: active (running) since Fri 2024-06-28 11:27:17 CEST; 1h 10min ago
       Docs: man:nginx(8)
    Process: 518 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_proces>
    Process: 524 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (co>
   Main PID: 526 (nginx)
      Tasks: 2 (limit: 1097)
     Memory: 6.8M
        CPU: 59ms
     CGroup: /system.slice/nginx.service
             ├─526 "nginx: master process /usr/sbin/nginx -g daemon on; master_>
             └─527 "nginx: worker process"

Warning: some journal files were not opened due to insufficient permissions.
lines 1-15/15 (END)

IP adderess show :

Visiting the IP address how Ngnix issues but te url not responding ?

Okay, now we know that nginx is running.
Now, is it actually exposing your Ghost instance?

Are there any nginx configuration files in /etc/nginx/sites-enabled?
Is a firewall blocking things?

server {
    listen 80;
    server_name quikseekr.com;

    location / {
        proxy_pass http://127.0.0.1:2368;
        proxy_set_header Host $host;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header X-Forwarded-Proto $scheme;
    }

    client_max_body_size 50m;
}


IP show NgnIX
and the website show error responding

netstat -ant | grep 2368 on the server - check that Ghost is actually on 127.0.0.1:2368, not the equivalent ipv6 address ?

marked as resolved, I reinstalled it in the wrong folder (permission issued related to the installation process).