Magic Link not loggin in users

I’m testing the subscription feature of Casper 3.0.12. I have Mailgun configured for transnational emails via config.production.json, and Mailgun is showing that the signup/login emails are sending. I’ve received the subscription and login emails to my test accounts, but when I click the link in the email, it doesn’t seems to sign in the user.
When I click the link for subscribing, it takes me to my page, shows the green bar up top saying “You’ve successfully subscribed…” but the subscribe button still exists and the member only posts are still hidden. This is the same with the login email.
I do see the members added to my list.

What can I check?

Thanks.

[UPDATE] ghost log shows

WARN Cookie ghost-members-ssr not found
INFO INFO “GET /?action=subscribe&success=false” 200 80ms
WARN jwt expired

This has to be what the issue is. Any advice?

Hey @BryChan, the above log makes me think you’re not clicking the link in time. Confirmation links sent in emails have a 10 minute expiry time for security reasons, the subscriber need to click the link within that 10 minute window to be successful :+1:

Thanks David,

I’m clicking the link within 2 minutes, so that can’t be the issue.

I get the green bar on top when I click the subscribe link saying “You’ve successfully subscribed…” but then the page doesn’t act like that account is. I can click subscribe, click the link that’s emailed to log in over and over again. Just never actually logs me in.

Maybe it’s worth making sure your Ghost installation is up to date? I think there’s been some more recent versions of Ghost than what you have. They could contain bug fixes for this.

Updated to

Ghost-CLI version: 1.14.1
Ghost version: 3.26.1 (at /var/www/ghost)

No change.
Last log:
[2020-07-23 14:35:28] INFO “GET /?action=signin&success=true” 200 108ms

It sure thinks it’s working, but it isn’t. I’ve tried multiple browsers, different IPs via VPN…

It’s as though it’s “signing in” the user, but not serving the user the page it would if they were signed in.

That log sounds better. Can I ask if there are any JavaScript errors on the page? They could be causing the listeners to break when the new subscriber lands on the page

No errors. I’ve tried the login/subscribe link in Chrome, Chromium, Brave, old IE and Firefox.

Hey @DavidDarnes,

I created an entirely new Digital Ocean Dropplet using their pre-built Ghost v3.27.0
Created two test posts, one public, and one members-only.

I recorded a video of myself going through the subscribing process.

I then attempted to subscribe, and I’m getting the exact same behaviour from a completely different install. What am I missing here?