Migrate from Tumblr / Install version 1.0?


#1

I’m attempting to migrate my blog from Tumblr to a self-hosted ghost. I have ghost installed, version 2.8.0, on Ubuntu 18.04 in a virtual machine server.

However, when I try to use the only migration tool I can find (http://tumblr-to-ghost.herokuapp.com/), I get the message:

Import failed

Detected unsupported file structure.

Please install Ghost 1.0, import the file and then update your blog to Ghost 2.0. Visit https://docs.ghost.org/v1/docs/install or ask for help in our https://forum.ghost.org.

I am new to ghost and really don’t know anything about JSON. I haven’t been able to find a way to install ghost 1.0, as everything I find installs the latest version.

I did search these forums, but didn’t find anything either.

Can anyone help by pointing me in the right direction?


#2

Hey there :wave:

If you’re trying to install Ghost 1.0, you need to run the install command with the v1 flag - ghost install --v1 or ghost install local --v1. Once you do that, you can create an account, import your v1 content and export it in a format ghost v2 will support.

Make sure you export your content just in case something goes awry, but after importing your content, you should just be able to run ghost update to fly up to ghost 2.x :tada:


#3

Thank you! I will try this!


#4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.