Sender name not used for newsletter nor login emails

I just set up a new Ghost instance (version 5.72.0) using a DigitalOcean droplet and configured everything. But no matter what I do, the sender name isn’t used:

CleanShot 2023-11-06 at 18.37.33

The thing is, I have a sender name set up in my settings:

I even set it in config.production.json:

I used to run my blog on Gloat Host, and there it sent emails with the set sender name no problem.

I’ve searched the forum and Google’d my finger off, but I can’t find any solution. And as it works fine on Gloat with the same version (5.72.0), I start to doubt whether I’m just missing something or if it really is a bug.

Has anyone run into this and know the solution? :pray:


The issue pops up in ProtonMail (but only with my self-hosted blog, not with Gloat), but not in Gmail:

CleanShot 2023-11-06 at 18.52.02

The setup in config.production.json is for transactional email only; not the newsletter. Go to the portal, ghost/#/settings/newsletters, to set the sender and reply to addresses.

Thanks for your reply @mjw. You confirm what I suspected.

As you can see in my original post, I have set everything up in settings yet it’s not working consistently:

I have no issue with Proton Mail displaying correctly. However, my config.production.json looks like this.

"mail": {
    "from": "",
    "transport": "SMTP",
    "options": {
      "host": "",
      "port": 587,
      "service": "Mailgun",
      "secure": false,
      "requireTLS": true,
      "auth": {

The sender is derived from the portal setting for Sender name, which I have left blank, resulting in the default setting, i.e., site name.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.