Can't update my From Address in config.production.json

Hi all,

I worked through the instructions here on editing config.production.json so that my Members newsletters would come from “Alex Karjeker <>”. I then restarted my Ghost, but my emails still send from “Texas Plenty <>”.

  "mail": {
    "transport": "SMTP",
    "options": {
      "service": "Mailgun",
      "host": "",
      "port": 465,
      "secureConnection": true,
      "auth": {
        "user": "",
    "from": "'Alex Karjeker' <>"

Any suggestions on what I’m doing wrong?

  • URL: .
  • Ghost Version: 3.26.1
  • Configuration:
    • Ubuntu 18.04 LTS (AWS Lightsail)
    • MySQL 5.7.30 (AWS Lightsail)
    • Static IP through AWS Lightsail
    • DNS managed via Cloudflare
  • Browser: Google Chrome 83.0.4103.119
  • Error Messages: None

The from-address for newsletters is a settings located in Ghost Admin under Labs/Members - it is not related to config

Yeah I was confused because I saw that setting and the linked doc above with “”from” instructions.

How do I include a name with my email? My recipients don’t realize it’s me because they know me personally not under the site brand.

@John - sorry to bump this.

But how do I change my sender name in Ghost? I don’t understand how to set it in the Ghost Admin, i.e. using quotes or bracket notation seems to cause an error

Closing and merging this issue with a larger thread: