Signup/login fails in Dawn theme with Portal (Beta)

This Ghost install was working just fine before updating to the latest version and installing Dawn.

Now I’m unsure what’s causing the problem (a bug in the theme or latest version?). But I’m sure my mail configuration is working because it has worked before.

When I click signup or login the portal opens but after submitting the email it says “Failed to sign up, please try again”. And I’m not alone, yesterday I saw the same error while trying to signup on Ghost’s official Dawn theme install (at dawn.ghost.io). Now it is fixed. I’d be really happy if someone from working on the theme helps us out on this.

Running on a Digital Ocean VPS.
Latest Ghost version and CLI.
Configured as per the official Docs and was working fine before this version and theme update.

1 Like

Hey @Dinakar,

Just visited your blog and tested the signup flow. It gave 500 error, so that means it’s something happened on the server. I would recommend you to check your Ghost instance logs for the errors.

Also here is a useful comment for configuring email settings for members, especially the section “Transactional Email” is the one you should look at.

3 Likes

Hey, thanks for the response.

But signup/sign-in and other emails were working fine before the update to the latest version and using dawn theme.

And like I said, I got the same error on Ghost’s official Dawn install (dawn.ghost.io) but now it is fixed somehow. I’ll grab my error log and post in a while.

I have also found another Ghost publisher with this issue here. I feel like it is something with the latest version or maybe with Portal as it is new.

I’ve had the issue with the latest version before the portal update, too. Now with Portal it looks just like your error on my site as well. I’m a bit confused wether “Please enter a valid email address” and “Failed to sign up, please try again” are words for the same error.

Since @Dinakar and me seem to have similar issues, I’ll post my ghost log here, hoping we’ll figure it out:

NAME: EmailError
MESSAGE: Failed to send email. Reason: Sending failed with error 451.

It seems I have to check mailing setup. But as mentioned in my own post, this only seems to be an issue for some users, which seems weird. Shouldn’t signin just not work at all if it’s a mail misconfiguration?

1 Like

Hey @minimaluminium and @sofakissen, I just fixed it. Here are the details:

Currently working configuration
/var/www/ghost/config.production.json - You can access these files on your server and make the changes accordingly.

  },
  "mail": {
    "from": "'Dinakar from Coulf' <postmaster@mg.YourMailgunEmailDomain.com>",
    "transport": "SMTP",
    "options": {
      "service": "Mailgun",
      "host": "smtp.mailgun.org",
      "port": 465,
      "secureConnection": true,
      "auth": {
        "user": "postmaster@mg.YourMailgunEmailDomain.com",
        "pass": "YourPassword"
      }
    }

What I have changed to make it work

"transport": "SMTP", (It was "transport": "Direct",)

"port": 465, (It was 587 as seen in the Ghost’s Mail Config Docs)

After making these changes I ran the ghost restart command for the changes to take effect.

I’m still unsure as to why this happened because previously it worked with the same setup and this is weird.

2 Likes

this solved my issue. I believe it is the transport method and port that is incorrect - it should be changed to SMTP and port 465. TY @Dinakar

1 Like

How do I edit this?

Just started using ghost. I’m not familiar with the technical side of it.

I’m using DigitalOcean’s Ghost Droplet.

@haikalkushahrin You have to access files from your server or through a file manager. I used WinSCP and then logged in with my droplet username and password and then it’s a matter of navigating/browsing for these files and editing it.

im having the same error can you help me out man I don’t even know how to access my droplet via ftp

this is what my mail portion looks like
},
“mail”: {
“transport”: “Direct”
},

Sure and it looks like you’ve figured out how to access files on your droplet.

Can you share more from your mail configuration part? It has to look like this:

I changed only this to make it work:

See this is what it looks like in my folder

You haven’t setup your email yet.

First, you have to setup emails according to Ghost’s official email docs, follow them step by step - link (https://ghost.org/docs/concepts/config/#mail)

That is, you have to add the missing code from my previous comments.

Simply get your Mailgun account credentials (‘user’ ‘pass’ etc) and replace it in the code that I sent.

1 Like

Thanks, Dinakar I’m having another problem also can you please look into this once Unable to get https: on www. its working fine without it

Glad you sorted it out.

I’m not really a tech person, so I think others will be able to help you. I didn’t read the thread fully but generally:

  • You can check your DNS settings. If you changed only now it’ll take some time to propagate.
  • As the reply suggested, try changing the domain name in both places.

Wishing you the best with your project!

Hey, @Dinakar I’m wondering if you could help me a bit too. I followed your tips there above and it helped me to get the transactional emails working. They all go through Mailgun now. But when I try to send a post as a newsletter, nothing happens and they don’t send. Nothing registers on mailgun either.

Know of a way I could troubleshoot this?

Are you seeing any error dialogs on the UI or from your error logs?

I’m not a technical person, so I won’t be the person to help you out but will try.

1 Like

Unfortunately no. It says after pushing send “Sending to members” but nothing happens after that.

Have you checked your error logs? If yes, can you share what it says here?

With that someone with technical knowledge from here or from Ghost’s team can help.

1 Like