Signup/login fails in Dawn theme with Portal (Beta)

This Ghost install was working just fine before updating to the latest version and installing Dawn.

Now I’m unsure what’s causing the problem (a bug in the theme or latest version?). But I’m sure my mail configuration is working because it has worked before.

When I click signup or login the portal opens but after submitting the email it says “Failed to sign up, please try again”. And I’m not alone, yesterday I saw the same error while trying to signup on Ghost’s official Dawn theme install (at dawn.ghost.io). Now it is fixed. I’d be really happy if someone from working on the theme helps us out on this.

Running on a Digital Ocean VPS.
Latest Ghost version and CLI.
Configured as per the official Docs and was working fine before this version and theme update.

Hey @Dinakar,

Just visited your blog and tested the signup flow. It gave 500 error, so that means it’s something happened on the server. I would recommend you to check your Ghost instance logs for the errors.

Also here is a useful comment for configuring email settings for members, especially the section “Transactional Email” is the one you should look at.

2 Likes

Hey, thanks for the response.

But signup/sign-in and other emails were working fine before the update to the latest version and using dawn theme.

And like I said, I got the same error on Ghost’s official Dawn install (dawn.ghost.io) but now it is fixed somehow. I’ll grab my error log and post in a while.

I have also found another Ghost publisher with this issue here. I feel like it is something with the latest version or maybe with Portal as it is new.

I’ve had the issue with the latest version before the portal update, too. Now with Portal it looks just like your error on my site as well. I’m a bit confused wether “Please enter a valid email address” and “Failed to sign up, please try again” are words for the same error.

Since @Dinakar and me seem to have similar issues, I’ll post my ghost log here, hoping we’ll figure it out:

NAME: EmailError
MESSAGE: Failed to send email. Reason: Sending failed with error 451.

It seems I have to check mailing setup. But as mentioned in my own post, this only seems to be an issue for some users, which seems weird. Shouldn’t signin just not work at all if it’s a mail misconfiguration?

Hey @minimaluminium and @sofakissen, I just fixed it. Here are the details:

Currently working configuration
/var/www/ghost/config.production.json - You can access these files on your server and make the changes accordingly.

  },
  "mail": {
    "from": "'Dinakar from Coulf' <postmaster@mg.YourMailgunEmailDomain.com>",
    "transport": "SMTP",
    "options": {
      "service": "Mailgun",
      "host": "smtp.mailgun.org",
      "port": 465,
      "secureConnection": true,
      "auth": {
        "user": "postmaster@mg.YourMailgunEmailDomain.com",
        "pass": "YourPassword"
      }
    }

What I have changed to make it work

"transport": "SMTP", (It was "transport": "Direct",)

"port": 465, (It was 587 as seen in the Ghost’s Mail Config Docs)

After making these changes I ran the ghost restart command for the changes to take effect.

I’m still unsure as to why this happened because previously it worked with the same setup and this is weird.

2 Likes

this solved my issue. I believe it is the transport method and port that is incorrect - it should be changed to SMTP and port 465. TY @Dinakar

1 Like