Unable to browse site - Memory Availability Error


#1

I am unable to browse my website nor ping it, but I can successfully ssh into my VPS host. Upon ghost doctor, it raises the error:

1) SystemError

Message: Ghost recommends you have at least 150 MB of memory available for smooth operation. It looks like you have 74 MB available.

My VPS has 1GB of RAM, and using the free command, it shows 467 MB of available memory and 868 MB of free swap capacity. I’ve read in another post here that this is only a bug with memory detection, so it should not cause real problems. So any way to pinpoint the real error? Thanks in advance!

Debug Information:
    OS: Ubuntu, v16.04
    Node Version: v6.14.1
    Ghost-CLI Version: 1.6.0
    Environment: production
    Command: 'ghost doctor'

#2

Hey :wave:t3:

Sorry to here that you’re having trouble. Yes, there is a known bug, but this is fixed now.

Can you please update the CLI (sudo npm i -g ghost-cli@latest) and try again?

You can also run the commands with the --no-mem-check flag to skip the memory check.

Let me know, if that solved the issue!


#3

The update did the trick :slight_smile: thanks. I think it might have also been the client’s network problem. Anyway, it’s fixed for now, thanks again!


#4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.